…Details…

Icon

Thoughts that's escape, only details.

Telecom Italia – IPv6 Pilot on Cisco

To my amazement, Telecom Italia released a pilot project of IPv6 deployment on residential/dynamic ip only adsl internet access, but on theirs support site there’s configuration only for some useless systems. So, I’ve decided to write a configuration for Cisco platform.

Usually the typical Telecom Italia PPPoE or PPPoA ADSL connection with dynamic IPv4 only was authenticated with “aliceadsl” as user and password, now with bran new credential along IPv4 the endpoint router advertise a IPv6 /64 class (always dynamic).

username: [email protected]
password: [email protected]

And now IOS configuration:

– ATM inteface:

interface ATM0/0/0
no ip address
atm restart timer 300
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 100 in
!
interface ATM0/0/0.1 point-to-point
pvc 8/35
vbr-nrt 380 380
oam-pvc manage
encapsulation aal5mux ppp dialer
dialer pool-member 1

– Dialer inteface:

interface Dialer0
mtu 1492
ip address negotiated
ip nbar protocol-discovery
ip flow ingress
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ipv6 address autoconfig
ipv6 enable
no cdp enable
ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password 0 [email protected]
ppp pap sent-username [email protected] password 0 [email protected]

– Route configuration:

ip route 0.0.0.0 0.0.0.0 Dialer0
ipv6 route 2000::/3 Dialer0

You can check with following command:

route01#sh ip int brief | sec Dialer0
Dialer0                    XXX.XXX.XXX.XXX    YES IPCP   up                    up
route01#sh ipv6 int brief | sec Dialer0
Dialer0                    [up/up]
FE80::1
2A01:2003:xxxx:xxxx::1

You can discover your /64 assigned class with:

route01#sh ipv6 int di0 | sec Global
Global unicast address(es):
2A01:2003:xxxx:xxxx::1, subnet is 2A01:2003:xxxx:xxxx::/64 [PRE]
valid lifetime 2591993 preferred lifetime 604793
route01#

I’ve left out NAT and other further configuration.

Update: prefix delegation

OpenVMS – IPv6

Memo about configure ipv6 on OpenVMS system as host mode:

First of all invoke the TCPIP$IP6_SETUP command procedure by entering the following command:

TARDIS::LEO$ @SYS$MANAGER:TCPIP$IP6_SETUP

Leaving default option to all question, in this mode the dcl create default configuration script.

Then edit the inet6 script:

TARDIS::LEO$ EDIT SYS$SYSTEM:TCPIP$INET6_CONFIG.DAT

After the “up” command

$ ifconfig "IE0" ipv6 up

Append the following line with ip and default gateway:

$ ifconfig "IE0" inet6 ip6prefix 2001:1418:0193:0001::40/64
$ route add -inet6 default 2001:1418:0193:0001::250 -"I" "IE0"

Save, exit and run the dcl:

TARDIS::LEO$ @SYS$SYSROOT:[SYSEXE]TCPIP$INET6_CONFIG.DAT

CentOS – IPv6 interface

You need to update and configure following files for IPv6 configuration:

1. Edit: /etc/sysconfig/network

And append following line, to enable in systemwide the ipv6 protocol:

NETWORKING_IPV6=yes

2. Edit: /etc/sysconfig/network-scripts/ifcfg-eth1 (or your interface number)

And append following line, to enable ipv6 on interface and the address/gateway if you use static routing:

IPV6INIT=yes
IPV6ADDR=2001:1418:0193:000B::210
IPV6_DEFAULTGW=2001:1418:0193:000B::251

Save, close and restart network service:

# service network restart

Linux – IPv6 Tunnel Broker

Come definire il link ad un tunnel broker i questo esempio HE.net da sistema operativo linux utilizzando i net tools

Prima parte crea l’interfaccia di tunneling sull’ipv4:

ifconfig sit0 up
ifconfig sit0 inet6 tunnel ::216.66.84.42

Seconda parte genera l’endpoint del tunnel in ipv6:

ifconfig sit1 up
ifconfig sit1 inet6 add 2001:470:1f12:11c::2/64

Terza parte definisce la rotta sul device relativo all’endpoing del tunnel per tutto il traffico ipv6:

route -A inet6 add ::/0 dev sit1

IPv6 – HE.NET Certification

Simpatica certificazione IPv6 inventata dalla Hurricane Electric:

IPv6 Certification Badge for leonardorizzi

Cisco IPv6

Anche se non credevo che fosse cosi’ semplice i tunnel 6to4 sui router cisco non sono una cosa complessa come sembra posto uno straccio di configurazione usato con il tunnel broker Hurricane Electric sul server di parigi:

interface Tunnel0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ipv6 address 2001:470:1F12:10A::2/64
ipv6 enable
tunnel source xxx.xxx.xxx.xxx
tunnel destination 216.66.84.42
tunnel mode ipv6ip
!
ipv6 route ::/0 Tunnel0

Attenzione questa e’ usata su un 2600 con IOS 12.3 IP FW IDS PLUS / IPSEC
Ricordo che e’ bene inserire un ACL che faccia passare il protocollo 41 solo dall’end point del tunnel e ovviamente lasciare le risposte icmp abilitate

IPv6

Visto che ogni tanto sale l’inutile fobia dell’imminente fine degli IP4 (cosa che reputo ridicola) ho deciso che era il momento di muovere un po’ la mia rete dato che iniziava ad essere abbastanza monotona.

Quindi dal 22 Luglio ho allocate due classi di ip:

2001:470:c86f::/48
2001:470:1f13:10a::/64

Gia’ che ero in vena di novita’ c’e’ pure un nuovo dominio stars6.net dedicato alle prove del caso.

Archives